https Verschlüsselung

Hier findet ihr Neuigkeiten zum Aquariumforum der Aquaristikfreaks
  • Aquariumforum - Aquaristikfreaks

Willkommen im Aquariumforum der Aquaristikfreaks
Warum geisterst du hier eigentlich noch als Gast herum?
Hast du keine Lust, dich mit gleichgesinnten zu unterhalten, sei es nun im Forum oder auch im Chat?
Wir sind ein kleiner netter Haufen mit dem gleichen Hobby, der Aquaristik. Egal ob es um Zwergbuntbarsche, Guppys, Welse oder Salmler geht, egal ob Züchter, Profi, Händler oder Anfänger, egal ob Süß- oder Meerwasser:
Jeder ist Willkommen!
Hast du vielleicht auch Lust an der Fischdatenbank der Aquaristikfreaks mitzuarbeiten?
Anmelden und helfen! Eine Fischdatenbank von erfahrenen Usern für Anfänger
Die Anmeldung ist komplett kostenlos und dauert keine 3 Minuten

https Verschlüsselung

Beitragvon Christian » 18.04.2016 22:11

Hallo zusammen

ich hab mich heute mal rangesetzt und das Forum auf https umgestellt.

Was bedeutet das für euch?

Die komplette Übertragung zwischen Server und euren Webbrowser findet normalerweise unverschlüsselt statt. Jede PN(*1), jedes Passwort(*2) alles was zwischen Server und euren Browser übertragen wird, wird im Klartext quer durch das ganze Internet übertragen. Dies ist schon lange nicht mehr zeitgemäß und es werden immer mehr Server auf das sichere https umgestellt.

Da ich dies zum ersten mal mache, lasse ich aktuell sowohl das unverschlüsselte http als auch das verschlüsselte https parallel laufen. Sobald ich sehe das alles einwandfrei funktioniert werde ich den unverschlüsselten Zugang abstellen.

Was müsst ihr tun um jetzt schon die Übertragung zu verschlüsseln?

Ruft das Forum nicht mehr mit http ( http://www.aquaristikfreaks.de ) auf, sondern mit https ( https://www.aquaristikfreaks.de ) und schon habt ihr, wie z.b. von Onlinebanking bekannt, das Schloss vor der URL stehen. Sobald ich sehe das sich das bewährt und ich sicher bin das keine Fehler mehr auftreten wird das normale http auf die verschlüsselte Seite umgeleitet.

Müsst ihr sonst noch etwas beachten?

Nein, dies geschieht alles automatisch, ihr müsst weder etwas installieren noch irgendetwas einstellen. Ich kenne kein Gerät das mit https Probleme macht somit sollten keine Nachteile entstehen, falls es dennoch Probleme gibt bitte unbedingt melden, Vielen Dank. Die Übertragung vom Browser zum Server ist einfach nur jetzt, wie bei euren Onlinebanking auch, verschlüsselt sonst ändert sich nichts.

(*1)Hier möchte ich kurz anmerken das PNs auf den Server unverschlüsselt gespeichert werden und theoretisch für mich einsehbar sind. Ich hab noch nie in fremde PNs geguckt und werde dies auch nicht tun. Dennoch sollten hier keine vertraulichen Daten versendet werden.
(*2) Das Passwort wird am Server verschlüsselt gespeichert und ist auch für mich nicht einsehbar, die Übertragung zum Server fand bisher aber unverschlüsselt statt.

mfg

Christian
Zuletzt geändert von Christian am 18.04.2016 22:19, insgesamt 5-mal geändert.
Benutzeravatar
Christian
-
-
 
Beiträge: 1773
Registriert: 20.07.2013 12:12
Wohnort: 90768 Fürth
Hat sich bedankt: 163 mal
erhaltene Bedankungen: 163 mal
AIPD: Zu meinem Fischbesatz

Re: https Verschlüsselung

Beitragvon jsc0852 » 18.04.2016 22:47

Moin,

habe das Forum gerade vom IPad Pro mit https aufgerufen und parallel mit meinem IPad Air 2 auf dem üblichen Weg.
Mit Https habe ich Antwortseiten von ca. 45 Sekunden, mit http nur ca. 5 Sekunden.
Dann beide Geräte umgekehrt genutzt und gleiches Verhalten festgestellt.
Werde morgen nochmal mit nem Mac testen.
Gruß aus dem Norden

Jörn
________________________________________________________________________________________________________________________
Meine Becken: 200l Südamerika, 150l Südamerika, 120l Tanganjika, 60l (zzt. leer), 7l (zzt. leer), 2*12l Aufzucht & Quarantäne
Meine Fische: Corydoras Paleatus & Pygmaeus, Rineloricaria Lanceolata, Nematobrycon Palmeri, Gymnocorymbus ternetzi, Hemigrammus erythrozonus, Nannacara anomala, Pterophylum Scalare, L333, LDA16, Neolamprologus Multifasciatus, Otocynclus vittatus
*** Wisst Ihr wie viel Arbeit ein geplatztes 120l Becken macht? Ich leider schon! ***
Benutzeravatar
jsc0852
-
-
 
Beiträge: 518
Registriert: 12.08.2015 21:44
Wohnort: Hamburg
Hat sich bedankt: 9 mal
erhaltene Bedankungen: 78 mal
AIPD: Zu meinem Fischbesatz

Re: https Verschlüsselung

Beitragvon Christian » 19.04.2016 06:58

Hi Jörn

selbst 5 Sekunden sind eigentlich viel viel zu lange. Bei mir läd die Seite eigentlich immer Instant. Ich werde es später mal bei mir noch mit diversen Geräten die ich hier habe testen. Danke für deine Mühe.

edit:
Ich hab gerade noch ein Problem entdeckt, die Buttons oberhalb der Schreibleiste (img, url, center, etc.) funktionieren nicht. Dies liegt daran das diese auf normales http gestellt sind. Sobald wir endgültig alles auf https umstellen werden auch diese funktionieren.
Die langsame Ladezeit könnte u.U. daran liegen, dass manche Grafiken noch unverschlüsselt ausgeliefert werden. Ich werde mich die Tage mal dransetzen und eine Weiche davor bauen, mal gucken obs dann besser wird.

mfg

Christian
Zuletzt geändert von Christian am 19.04.2016 09:06, insgesamt 2-mal geändert.
Benutzeravatar
Christian
-
-
 
Beiträge: 1773
Registriert: 20.07.2013 12:12
Wohnort: 90768 Fürth
Hat sich bedankt: 163 mal
erhaltene Bedankungen: 163 mal
AIPD: Zu meinem Fischbesatz

Re: https Verschlüsselung

Beitragvon Christian » 09.05.2016 06:50

hi

nachdem beides parallel etwas schwierig ist, werde ich das https testweiße am Donnerstag den 12.5 irgendwann morgens komplett aktivieren. Sollte es danach zu Probleme kommen und ihr kommt nicht mehr ins Forum, meldet euch bitte unter aquaristik@chrisi01.de

Ihr solltet von der Umstellung eigentlich nichts merken, normale Aufrufe werden einfach auf https umgeleitet.

mfg

Christian
Zuletzt geändert von Christian am 09.05.2016 06:51, insgesamt 1-mal geändert.
Benutzeravatar
Christian
-
-
 
Beiträge: 1773
Registriert: 20.07.2013 12:12
Wohnort: 90768 Fürth
Hat sich bedankt: 163 mal
erhaltene Bedankungen: 163 mal
AIPD: Zu meinem Fischbesatz

Re: https Verschlüsselung

Beitragvon Christian » 11.05.2016 23:05

hi

wie bereits angekündigt habe ich nun alle Anfragen auf das verschlüsselte https Protokoll umgestellt.

Ich hab diverse Forenfunktionen getestet und auf mehreren Browsern und Endgeräten sowie Betriebssystemen keine Fehler festgestellt.

Das einzige was jetzt passieren kann ist, dass ihr euch neu einloggen müsst da u.U. das alte Cookie nicht mehr gültig ist. Dies sollte eine einmalige Aktion sein und danach solltet ihr wieder normal eingeloggt sein. Falls dies nicht der Fall ist, ist es u.U. sinnvoll alle Cookies von aquaristikfreaks aus euren Browser zu löschen, spätestens dann sollte alles gehen.

Falls es zu Problemen kommt, einfach bei mir melden dann werde ich gucken was ich tun kann.

mfg

Christian
Zuletzt geändert von Christian am 11.05.2016 23:06, insgesamt 1-mal geändert.
Benutzeravatar
Christian
-
-
 
Beiträge: 1773
Registriert: 20.07.2013 12:12
Wohnort: 90768 Fürth
Hat sich bedankt: 163 mal
erhaltene Bedankungen: 163 mal
AIPD: Zu meinem Fischbesatz


Zurück zu News

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron
<